Oh No, Our Server, It's Broken ๐Ÿ˜ฑ

Resolved
Operational
Started over 2 years ago Lasted 5 days

Affected

Website and Portfolio
Updates
  • Resolved
    Resolved

    We are happy to announce that we are updating the status to "Resolved" with this incident ๐ŸŽ‰ Once again we are deeply sorry for the long incident and for the inconvenience this may have caused. Furthermore, please don't hesitate to reach out to us, if you run into any further issues.

  • Monitoring
    Update

    We are happy to announce that it appears all websites and services have now been fully restored ๐ŸŽ‰ We will continue to monitor for further outages and if all good tomorrow by 12pm (PST) we will flag this incident as "Resolved"!

    Once again we deeply apologize for the inconvenience this may have caused.

    Thanks, Donald Louch, CEO and Founder of DevLexicon

  • Monitoring
    Update

    We're happy to announce that the majority of our websites are back up ๐Ÿ™Œ๐Ÿป these include:

    Unfortunately, we're still having issues with the main DevLexicon website and portal, along with the Donald Louch blog and portfolio website. and OpusVid. In addition DevLexicon Themes are still further, having issues. We're hoping to have this fixed shortly ๐Ÿคž

    Once again, if you continue to face issues with the listed websites above, please don't hesitate to reach out to us!

  • Monitoring
    Update

    The feeder domains should be once again active for:

  • Monitoring
    Monitoring

    The email servers should be back up now ๐ŸŽ‰ some further configuration maybe needed. But will keep this post updated!

    If emails don't go through, we do apologies and ask if you could reach out to us via. social media to inform us.

  • Identified
    Identified

    COMPLETED: We have installed our CyberPanel hosting panel ๐ŸŽ‰ we're now currently reconfiguring the panel and server.

  • Investigating
    Update

    COMPLETED: We have re-flashed our server and have began the process of reinstalling our hosting panel (CyberPanel)

  • Investigating
    Investigating

    We have stopped our email server and that did help with the CPU usage, however, it seems there is a lot more going on with the server. From the our investigations, it seems that there is quite a bit of broken configurations.

    Within saying that, we have decided that we are going to re-flash the server and re-upload all the content.

    This process may take sometime and once again we thank you for your patience and sorry for any inconvenience this may cause.

    We will post further updates on our progress. During the re-flashing process all redirect URLs such as YouTube, Facebook, Instagram, LinkedIn will not be active, but the accounts will still remain active and can be found rather at @DevLexicon or @DonaldLouch. In addition, DevLexicon Links will remain active on the deployed Vercel link which will be devlexiconlinks.vercel.app instead of links.devlexicon.ca.

  • Identified
    Identified

    We believe we have found the root of the issue? It seems that that our mail server is running our CPU into an overload.

    We are looking into the solution and should hopefully have a fix soon ๐Ÿคž

    Thank you for your on going patients!

  • Investigating
    Update

    We are still facing the outages and have submitted a ticket with our hosting provider as we arenโ€™t even able to login to the server for troubleshooting.

    We apologize for an inconvenience this may cause.

    We will post a further update once available.

  • Investigating
    Update

    We're still investigating this issue. Within saying that, it now appears to be affecting the loading of all websites and services now.

    Possible Issue: CPU processor overload?

    We'll post another update tomorrow morning (November 15th, 2021)

  • Investigating
    Investigating

    We are currently experiencing major outages across our websites and services. This is primarily affecting any database connections and email services.

    We are currently investigating this incident.